Durant une migration d’ESX 3.x vers ESXi 4.1 j’ai du procéder à l’ajout d’un host ESX 3.0 dans mon nouveau vcenter 4.1. L’opération s’est terminé à chaque fois par le message : « Cannot install the vCenter agent service. Cannot prepare the host for upgrade. »

ARGH !! J’avais déjà effectué la manipulation sans problème avec d’autres ESX mais en 3.5 … 😕

Une petite recherche Google m’a permit de trouver une solution simple ! En fait, le Vcenter essaye d’accéder à un répertoire ( /tmp/vmware-root ) qui n’existe pas sur l’ESX et ne peut donc pas procéder à la mise à jour de l’agent.
Solution :

On se connecte en SSH sur l’ESX qui pose problème en tant que root.
# cd /tmp
# mkdir vmware-root

On se déconnecte et recommence l’ajout de l’ESX dans le Vcenter : Là ca doit fonctionner ! 😀

Catégories : Vmware

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.